Some Rx packages not yet published on NuGet

Jun 10, 2011 at 1:42 PM
Edited Jun 10, 2011 at 1:50 PM

Hi Jose,

Thanks for sharing this project!

Today I forked the project and cloned via Mercurial but when I run the scripts to fetch all packages, NuGet is unable to fetch the Rx-* packages and the project does not compile.

e.x.: When I search for the Rx-AsycLinq project on NuGet I get "This is not published" (here is the link: http://www.nuget.org/List/Packages/Rx-AsyncLinq)

Any ideas on automating the build without including the assemblies on source control?

 

Thank you,

Nikos

Coordinator
Jun 10, 2011 at 1:50 PM

Hi Nikos,

yes you are right it seems that they changed something.... 

Thank you for reporting. i will fix it right now.

Coordinator
Jun 10, 2011 at 1:59 PM

done! Do a "pull" and an "update" to last version.

On the other hand you don't need to run the batch file, just open your visual studio and build the projects. It will download the automatically all dependencies.

If you want to know how to do this in your own projects, i blogged here: http://joser.info/jzcSHR

If you have any question regarding the code don't hesitate to contact me in this forums.

thank you very much.... 

Jun 10, 2011 at 2:22 PM
Edited Jun 10, 2011 at 2:24 PM

I saw the blog post while I was reading the documentation! That's very very cool and useful!

Now that I updated to latest version, I did a project build and it succeded. (So both, the MSBuild Task and the last version of ReactiveExtensions update worked together!)

I had a look in the source code, besides the great Restbucks .NET impl., the project itself contains a lot of best practises on NHibernate (Net4CollectionTypeFactory,  LazySessionContext) and Windsor (custom installers for NHibernate, ISessionFactoryProvider to name a few).

Thank you for sharing!

Jun 14, 2011 at 6:45 PM

Hi,

 I'm getting "Unable to find version '1.1.10425' of package 'Rx-Main'." (downloaded the latest changeset 5 minutes ago).

 --larsw

 

Coordinator
Jun 14, 2011 at 6:54 PM

Hi Larsw... fixed. It seems that they are doing it wrong. 

They delete and recreate the project each time they publish a new version, so nuget doesn't have the old version :(

Jun 14, 2011 at 7:03 PM

Ok, I'll manually add Rx and fix the dependency stuff myself for now.

 --larsw

Coordinator
Jun 14, 2011 at 7:04 PM
It is fixed in my last push!

2011/6/14 larsw <notifications@codeplex.com>

From: larsw

Ok, I'll manually add Rx and fix the dependency stuff myself for now.

--larsw

Read the full discussion online.

To add a post to this discussion, reply to this email (restbucks@discussions.codeplex.com)

To start a new discussion for this project, email restbucks@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com